Digital Photo Organization

Organizing
& Using
Digital photos

From Shooting/Scanning to
Storing and Sharing



Why Organize?
50 years ago there was a shoebox

- Room for maybe a few hundred photos

Then came the Photo Album
- Maybe room for a few thousand

Now there's a computer and
- Room for many thousands

So How do you find that photo?



First Get your Photos into Computer

Option 1 — use program that came with camera

- But, do you know how to or even want to use this
program??

- Can this program bulk re-name? Does it help
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Organize? It's “free” so don't expect much.

Option 2 — connect camera or remove card and put
into a card reader
- Then look in My Computer and one of the “Disk
Drives” is now your camera or card
- Now just copy and paste contents to folder of your
choice



Photos on your computer

* Initially put photos into a folder called something like
“New Photos”

* Check that the transfer worked then format the card
iIn the camera to delete the photos!

 Now re-name your photos with a name that means
something

 The idea is to add “intelligence” to the folder and file
names so they mean something to you.



But renaming can be a pain

* In Windows, the simplest bulk renaming is:
- select a group of files
- Choose rename from right click or file menu
- Type a name

* Windows will change the names so that all files have
the same name but with a numerical sequence



Anything better?

Use Photoshop Bridge or a similar program that
provides for Bulk renaming
Use a renaming Utility like the one in IrfanView or
the stand-alone CKRename
The hard part is to remember to do it before you
modify any photos
With files renamed, almost any folder system or
organizing system will work.
- | use Photo Shop Album 2 (Version 3.2 now free)
- Picasa would work too (free — auto organizes by
date)
- Or even just Windows — Vista is similar to PS
Album



Next step

Shooting in RAW means you will modify 90% to
100% of the photos

Even shooting in jpeg means some photos will have
something adjusted

Keep the originals in case you screw up or just
adjust poorly!
- | just have a folder (e.g.) Originals 2007

Modified photos will be same name but stored
elsewhere.



Organize Folders

* Group the folders in a “tree” that makes sense
- E.g. Main folders by month with sub-folders by
event or type of subject or client
- Or the other way around - type of subjects with
subfolders by date
- Pick a method you are happy with but do it!
* Don't forget to move photos from the New Photos
folder to something else



Summary of Work Flow

 Make sure you have a suitable collection of folders
- | start with “Latest Photos” then move later
Move photos from your Camera to Computer
Rename

Do any RAW and/or basic corrections

Save into organized folders



Corrections - 1

* You can't correct bad compositions — or at least not
easily

 Only in RAW can you correct exposure and then
only a stop or two.

* You can't fix focus errors — although you can and

should sharpen a bit.

You can't fix depth of field errors

So what can you fix?

Note: the following assumes you are using
PhotoShop or Photoshop Elements.



Corrections — 2

* White balance is often wrong
- the easiest way to fix it is to use a “levels” layer
and sample something that should be grey (e.qg.
an old person's hair!)
- If it is too much, back off using opacity less than
100%
« Contrast and/or brightness sometimes could need
tweaking
 Maybe a touch more saturation would add zest
* Always try a little more sharpness — but don't overdo
— if there are white lines on borders you've way
overdone it.



Sharing Photos

 |f you have a good camera, the file size when you
are done will be at least 2 to 4MB.

* This size is ready to print — as is.

« But emailing needs about 100KB each! That's 20 to
40 times smaller.

* And for sharing on our web site or showing on the
projector, the size (in pixels) should be no larger
than 1024 x 768 and no larger than 1MB



Cameras and Formats

Photo size starts as pixels
- e.g. 3000 x 2000 = 6MP

There are 3 pixels per colour, each needing 8 bits =
typically 144Mbits or 18MBytes (= originals are big!)

Most cameras process these inside the camera into
approx. 2 - 4MB jpeg's for high quality or larger for
RAW

Scanners often produce TIFF files with no
compression so are quite large



Formats on the Computer - 1

* Once downloaded (and for RAW, after processing),
photo will be about 2-4MB jpeg but still 6MP

e To print, you will need all the pixels and all the bits
you can get.

- Compressing below “high quality” will blur or
cause pixelation — especially noticeable on large
prints

* For showing on a projector, you need to keep quality
high (compression low) but reduce pixels to 1024 x
/68 or whatever the capability of the projector is.



Formats on the Computer — 2

 To email, you need a small file size (in bytes)

* File should be resized to fewer pixels because you'll
then need fewer bytes

 Computer screens are typically 1024 x 768 so
choose 1024 pixels wide

* File should also be compressed or reduced in quality

 Choose medium or low quality so that the file size is
60 to 200KB

Note: Resolution (ppi or dpi) is of no concern until you
print — ignore or use default for this setting.



How to change file size

» Use a photo editing program
 First change pixels
* Then change quality

* E.g. In Irfanview
» choose Image>Resize/Resample then choose size
wanted (e.g. 1024 X 768)
» Choose File>Save as the file type jpg then quality
60 (medium)
« Experiment with quality till you get size (KB) you
want

e Get Irfanview free at www.irfanview.com



IRFANVIEW 1
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IRFANVIEW 2

.
* Open afile e — =

View = X

 Go toimage >
Resize/Resample

-

1280 960 24 BPP  2f11 92% 744.29KB[3.52MB  22/10{2007 [ 07:36:17




IRFANVIEW 3

e Choose size |

|| Resize/Resample image

Wa n ted 3 Some standard dimensions:
. = Current size: 1280 = 960 piels
° C O __ Hall Double
IICk K 33 1280 = 960 pixels [ l [

M ew size:
() B0 x 480 Pixels
(%) Set new size: () 800 » BO0 Pixels

Wwidth: | Height: | 950 () 1024 » 768 Pixels

Urits: (3 pivels 0 em () inches (1280 » 960 Pixels
(1600 « 1200 Pixels

() Set new size as percentage of original () Best fit to desktop
Width: |:|?<.’ Height: | 100 i () Desktop size [ho aspect ratio)

Size method;
Frezerve azpect ratio (%) Resample [better quality)

Fezample filter:
CPl: 72
:I Lanczoz filter [glowest)

() Resize [faster)

aE. ] ’ Catizel ]




IRFANVIEW 4
Choose File> Save as Type jpeg — below => 186KB

Save Picture As ... JEEF* 58

JPEG:

Save in: | (2 My Pictures

Save gqualiy: €

[ ] Save as progreszive JPG

[ ] Save as grayzcale JPG [please remember!]
[ ] Dizable color subzampling

K.eep ariginal EXIF data

K.eep anginal IPTC data

K.eep onginal JPG-Cormment

GIF:
[ ] 5ave interllaced

[ ]5ave tranzparent color
Chooge transparent colar during saving

annie.jpg deskkop-computer, jpg

limba. jpg noosaz, jpg northshorel . jpg o

| Set trangparency value to palette entny:

File narme: beach | S ave

Save az tppe: | JPG - JPEG Files | Cancel |

[ ] Save with ariginal datetime Show optionz dialog [ ] Detailz




IRFANVIEW 5

 Can also Batch Convert and rename!
* Do limited colour adjustments

e Run a decent slide show



IRFANVIEW 6 — Batch processing

* First be sure you know which folder the photos are in
and create a destination directory e.g. “Resized
photos”.

 Choose File>Batch Conversion Rename (or press B)

* Navigate Look in until you find photos to be
processed

« Highlight wanted pictures then click Add

« Under Output directory, navigate to the folder where
the modified files will go.

* Go to “"Work as” and select Batch Conversion —
rename result files.
* Check Use Advanced options
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Batch conversion

Input files:  [23])

C:ADocuments and SettingzshJohn Drag
C:ADocuments and SettingshJohin Drag
C:ADocuments and SettingshJohin Drag
C:ADocuments and SettingshJohin Drag
C:ADocuments and SettingzhJohn Drag
C:ADocuments and SettingzhJohn Drag
C:hDocuments and SettingzhJohn Drag
C:hDocuments and SettingzhJohn Drag
C:hDocuments and SettingzhJohn Drag
C:hDocuments and SettingzhJohn Drag
C:ADocuments and SettingzhJohn Drag
C:ADocuments and SettingzhJohn Drag
C:hDocuments and SettingzhJohn Drag
C:hDocuments and SettingzhJohn Drag
C:hDocuments and SettingzhJohn Drag
C:ADocuments and SettingzhJohn Drag
C:ADocuments and SettingzshJohn Drag
C:ADocuments and SettingzshJohn Drag
C:ADocuments and SettingshJohin Drag
C:ADocuments and SettingshJohin Drag
C:ADocuments and SettingshJohin Drag
C:ADocuments and SettingzhJohn Drag
C:ADocuments and SettingzhJohn Drag

£ *

Preview image

Start
Cancel
Add
Add all

Remove

Remowve All

Sart filez
Load TeT

kMove up

Mowve down

Preview

Loak in: | I For downgizing

1| Brittany 2007 036.jpg

| Erittany 2007 268 jpg

‘1_‘.] Brittarny St Malo 2007 156.§pg
‘1_‘.] Brittary Sk Malo 2007 155.ipg
,l_‘.] Brittany St Malo 2007 185.ipg
,1_‘.] Monacoz_059.jpg

£

File name:

Filez of type: | Cormmon graphic Files

v O ;i

,1_‘.] MonacoZ_079.jpg

.1_‘.] MonacoZ_091.jpg

.1_‘.] MonacoZ_112.pg

1| Monaco 2007 329.jpg

,1_‘.] Monk 5t Michel 2007 103.ipg
,1_‘.] Mont 5t Michel 2007 119.jpg

[ ] Include subdirectories

IJze thiz directony as output ]

Olutput directany:

2)X]

M
| P
| Pe
1| 5:
i) =5:

,l_'.]Se

Document: and Settingzhohn Draperibde DocumentzhDownszized

Whork as:
") Batch conversion
{1 Batch rename

{#) Batch conversion - Fename result files

Batch comversion settings:
Cutput format;

JPG - JPEG Format
Batch rename zettings:;

W

Set rename options

Use advanced options

O ptions ]

[ Set advanced options

Wame pattern; |Jobn Draper's Album _ Dec 2007 ##




IRFANVIEW 8

settorallimages: K

[ ]CrROP:
#-Coord.; '-Caard.;
Y fidth: Height:
RESIZE:

(%) Set new size:

() Set both sides to;

Wfidth: Height:

{E} pixels
(%) Set long side to; 1000 | ) em
() Set short zide to; () inches

() Set new size as percentage of original
Width: %, Height: 4

Preserve azpect ratio [propartional)
Ilze Resample function [better quality)
Don't enlarge zmaller images

Set DPFI:
[ ] CH&WGE COLOR DEPTH:

[£ - 256 colors]

Load zettings ][ Save settings

OTHER OPTIOMS:
[ ] Harizantal flip

[ ]wertical fiip

[ ] Rotate left

[ ] Ratate right

[ ] Comvert to greyscale

[ ] Megative

[ ] Sharpen: 1 1 - 99

[ ] Brightriess: [-25h - 2RA]
[ ] Contrast: [127 - 127]
[ ] Gamma comrection: (001 - 6.99)
[] 5 aturation [-255 - Z5R]
[ ] Color balance - R: [-255 - 25A]
[ ] Color balance - G: [-255 - 25A]
[ ] Color balance - B: [-255 - 255

MISCELLAMEOLS:
[ ]| Canvas size

[ ] Add overlay text

[ ] Ovenwrite existing files

[ ] Delete original files after conversion

[ ] Create subdirectories in destination folder
S ave filez with original datetime

[ ] &pply changes to all pages [if TIF saving)

| |

[ ak. Cancel ]




IRFANVIEW 9

* Rename and
numbering

e Sample will name
all files:

“John Draper's
Album Dec
20077

With a 2 digit

sequential

number

Mame patter:

Batch rename settings

John Draper's Album - Dec 2007 B8

M = gld file hame, without extension
# = ohe digit, nurmber

For numbers, digits:

Starting index:

Replace text [1]:
Replace test [2]:

Replace text [3]:

1 lncrement: |1
with
with

ity

Q. | | Cancel

B




IRFANVIEW 10

e Choose Output Format Options

* Choose 60 Quality
* Check keep data
* Click Start

JPEG,/GIF save options

JPELG:
lowest G0

Save qualty; €

[ ] Save as progressive JPG

[ ] Save az grayzcale JPG [pleaze rememberl]
[ ] Dizable color subzampling

F.eep anginal ExIF data

F.eep anginal [PTC data

F.eep onginal JPG-Cormment

GIF:
[ ] Save interlaced
[ ] Save tansparent color

| ak. | | Cancel

best




Other Programs

Adobe Photo Shop Album Starter 3.2 — Good
organizing and simple adjustments — free

Google Picasa — good organizer (but no tags) and
simple adjustments — free

Adobe PhotoShop Elements 6 — very good
adjustment capability, good organizer $75

Adobe Photoshop CS3 (includes Bridge). Best in
class adjustments, $649. Bridge is good organizer
but no tags.



Club Sharing — web site

e Send 8 photos to John Draper by email, CD or
prints for scanning.

e These will go in members gallery

* OR

* Go online to new gallery that allows for
comments, self-uploading etc. Members can
upload up to 50 photos at 1024 pixels and IMB
each.



Questions?

Download Irfanview from www.irfanview.com

Download CKRename from
www.cobourginternet.com/images/downloads/Ckrn_108.zip

Download this presentation — printable and original versions at
www.northumberlandfilm.ca/program.htm - go to Jan 7 presentation.


http://www.cobourginternet.com/images/downloads/Ckrn_108.zip
http://www.northumberlandfilm.ca/program

